Hörmann IT-WLAN HomeKit connectivity fix

Hörmann IT-WLAN is a HomeKit accessory for Hörmann garage doors. Unfortunately, its WLAN module is very picky with Wi-Fi settings, and it generally has problems when we try to control it outside the local Wi-Fi network.

I had too many problems with it both in local network and from a cellular connection. It generally worked correctly from the local network, but occasionally I got the dreaded No response error. When I opened the garage door from the local network, entered my car and got out it nearly never worked with the cellular connection. Sometimes, after 20 minutes or so, it would start working.

Pinging the device would lose 5% or more pings every time.

I have a Linksys Velop mesh network at my house. Putting one node in the garage did no improvement. Unfortunately it does not have any expert configuration options. I tried an old AirPort Extreme which was even worse. Pinging the device constantly made a little improvement, but did not go far. So, I decided to live with the situation until I remembered an Asus DSL-AC68U lying unused.

I put it in the garage as an access point. For the 2.4 GHz network, I configured the following:

  • DTIM Interval: 1
  • Beacon Interval: 50 ms
  • Airtime Fairness: Disable

That’s all. The device immediately started working correctly. No ping losses, no No response errors. Moving between the local network and cellular connection does not create any problems. The device is always responsive. Even CarPlay started working correctly as long as iOS remembers to update the CarPlay interface. Sometimes that does not happen and you need to launch the Home app on the iPhone, but that immediately corrects the situation. That is an iOS problem though, not IT-WLAN‘s.

So, if you also have problems with IT-WLAN, just put an access point device with expert configuration options near it and configure the above settings.

UPDATE: I am currently using a TP-LINK EAP-225 Outdoor instead of the Asus DSL-AC68U with 40 ms beacon interval. I also changed the 2.4 GHz network to 802.11 b/g only. It seems to work even better with this configuration.

4 thoughts on “Hörmann IT-WLAN HomeKit connectivity fix”

  1. Hi!

    The Linksys Velop has a hidden web interface that has more settings.

    1. Connect a computer to the Velop.
    2. Go to 192.168.1.1 in a web browser. A page with the heading “Download the Linksys app for setup” will be displayed.
    3. Click on the image of the app on the left. (Your pointer won’t change when you hover over the image.)
    4. Log in to the interface. (The default password is “admin”.)
    5. Click on “CA” in the bottom-right corner to access all of the Velop’s settings.

    I don’t have a Velop but I’m planning to get one. I want a router with HomeKit but I don’t want to create an account to use the router, which is why I know about its hidden web interface.

    Please let me know if there are any settings for HomeKit in the web interface and if you get the Hörmann IT-WAN and the Velop to work together (I’m also planning to get the IT-WAN).

    😊

    1. I know about the interface but as I remember that does also not have any expert settings. I’ll surely let you know after checking it. (UPDATE: The interface does not have any configuration ability for HomeKit or expert settings)

      I’d recommend Orbi instead of Velop though. It has much better coverage.

      1. Hi,
        Using netgear orbi with the hormann it-wlan and it has worked for 2 weeks.
        First set up was perfect, 1 minute, open from local and outside my home.
        I had a wifi reboot du to electricity failure on my isp modem (not the house) and It never came back to life. I have a butifull button that flashes in my garage. I tried everything… reset all the device… the accessory. Don’t know. If you can help 🙂

        In the meantime, my phone was update to iOS 15, maybe that’s it…

        1. I think IT-WLAN does not like mesh devices. My setup has changed slightly since I wrote this. I currently use a TP-LINK EAP-225 Outdoor in my garage while the house has a Linksys Velop mesh. The TP-LINK has a different WLAN name for the 2.4 GHz network than the house and it is set to 802.11 b/g only. I have no problems whatsoever. Perhaps you can try a configuration like this. I also use iOS 15 at the moment.

Leave a Comment

Your email address will not be published. Required fields are marked *